GR User Forum

The spot for all Ricoh GR camera users

Register for free, meet other Ricoh GR users, share your images, help others, have fun!

Tell your friends about us!

GRD often hangs after upgrading to 2.30/2.31

GRD often hangs after upgrading to 2.30/2.31 and it seems it has something to do with ADJ button.

Problem is for example discussed here.. ... e=24306889
or here.. ... 1249918412

Report made by DPReview user Sloppy:
yesterday i updated the firmware on my GRD to version 2.31W from the ricoh website. I realized a strange problem after that.

If I am in photo mode (M or A etc.) and push the ADJ. dial TWICE, the camera hangs up. The live-view still works but has a little delay and the on screen menu (in my case the ISO pulldown menu) freezes. It's even impossible to swith the camera off. After a time and pushing some buttons (30 seconds or a minute), the display turns off by itself. When I push the power button after that, the lens makes some noise but stays extended and finally the camera is in photo mode again. Alternatively I can push the playback button, which makes the lens retract with some additional noise and then the camera is in working playback mode.

This problem occurs each time when I press the ADJ. dial twice. I don't know if this problem occured after updating the firmware because pushing the button twice makes no sense, so I can't remember doing it before. I downgraded the firmware to version 2.30, but the problem is still there =(

Status: confirmed by users (reported to Ricoh)

Temporary solution:
I found out, that you can avoid a freeze of the system when not using the press-button functionality of the ADJ. dial. I hope Ricoh will fix this in the next firmware update. Until then I set up ISO etc. via the camera menu. This can be done also quickly by pressing the menu button and walking through the menu by using boths dials.
Example for chaning ISO:

press menu/ok -> turn front dial one click to the left -> turn rear dial one click to the right -> turn front dial to choose the ISO setting -> press menu/ok

That's a little more buttons to press, but with some practice you can navigate through the menu very quickly by using the dials.

thanks for posting my report here (Kamil = Sloppy). I hope we can attract Ricoh's attention. I think, I should mention, that the actual solution, not using the ADJ. button has another disadvantage.
If you recorded a movie or a sound clip with the GRD, you can't play it without using the ADJ. button in playback mode, so it's a bit like Russian roulette when trying to playback a movie/soundclip. I experienced also several system hang-ups here.

Greetings, Kamil.
I hope they will fix it. Do you have any idea in which previous FW version it worked OK? Is it really only 2.30 or 2.31 problem? I believe you should still be able to install older FW versions over new?
I had no problems with 2.30, so I tried also to downgrade the firmware to 2.30 again. This works, but the problem was still there after downgrading, although in the camera info 2.30 was displayed. I wonder if downgrading to the oldest firmware and then upgrading to 2.30 again would clear the problem but I'm a little bit afraid of crashing my camera completely with this method.
Hello, first post as I've just come to the forum, via Dpreview forum . . .
I've upgraded my v2.20 GRd to v2.30 using the SD card method, and have no problems so far, with either the camera or the Adj button wheel.
Curious that the 'Restore Defaults' setting has gone . . .

Kamil, as we just realized how to enable the "Restore Defaults" options even in FW 2.30, (see this), I would suggest you to try to restore your default camera settings, as suggested before. Hope this helps now? ;)
Ok, I tried to initialize the camera via the auto mode, but after that, the problem is still there. I had just to press the ADJ. button a few times and the camera freezed again. This method to initialize the camera only resets the shooting settings. All other settings in the "setup" menu like the af assist light or lcd brightness are unchanged after this reset.

Greetings, Kamil.
OK, thanks for test Kamil! I've already asked Ricoh about this problem and also if there is a similar camera initialization (master reset) procedure the known procedure for GX100. Hope they will answer ;)
OK guys, just got a reply from Ricoh Japan (finally) about this problem. Unfortunately, nothing positive..
Dear Pavel Kudrys,

Thank you for contacting Ricoh Japan,

Thank you for your report on the GR Digital.
But please understand that basically we will judge any issue after checking
a camera.
If you have a hanging issue, I would recommend contacting our service
In European market, Ricoh PMMC Europe will assist you.

Regarding the master reset, I am afraid that we will not open the
For the customer's reset, please have a look on page 92 in the GRD camera
user guide.
The Restore Defaults menu appears at the Still Image Mode (camera mark).

Sincerely yours,
Ricoh PMMC Japan
Customer Support Digital Camera Products

But at least we now know that there most probably IS a master reset for GRD! Keep pushing your GRD buttons! ;) I'm sure, the procedure will be very similar to "Master Reset" procedure for GX100.