GR User Forum

The spot for all Ricoh GR camera users

Register for free, meet other Ricoh GR users, share your images, help others, have fun!

Tell your friends about us!

Weird error with SD card - GX100 addicted to Sandisk?

hiro

New Member
When I first got my GX100 I was using a My Memory brand 2GB CD card in it, but soon replaced it with a Sandisk Extreme III because raw writing speeds were extremely slow.

Recently I put the My Memory card back into the GX100 and the weirdest thing happened. The first thing that happened was that the camera ignored the card and wrote the picture to internal memory instead. (I didn't notice that it was using internal memory until after I'd taken a picture). Thinking I must have not inserted the card fully I reinserted it and turned the camera on again. This time an error number flashed up (which unfortunately I failed to note before it vanished) and the camera went dead with lens still extended.

On replacing the card with the Sandisk one and toggling the power button it went back to normal with the lens retracting and everything ok again. Taking a chance, I put the My Memory card into my old Panasonic FX01 and it worked fine. I reformatted it in the FX01 (obviously I couldn't reformat it in the Ricoh which would have been preferrable) and tried it again in the GX100. (I also took the precaution of changing the battery in the GX100 for a freshly charged one in case this had been the problem.) Once again it went completely dead as soon as the lens had extended, but was again cured by putting the Sandisk card back in and toggling the power.

Has my GX100 become addicted to Sandisk cards? Were these withdrawal symptome? Or has my old SD card gone faulty in a subtle way that kills the GX100 but leaves the FX01 unaffected?

I would note that I don't think the problem can be to do with the card having been used in another camera, since prior to this incident I had often played "musical cards" between three cameras and an MP3 player with no ill effects at all. Each device makes its own proprietary-name directory for its files on the card and simply ignores the directories made by the other devices. (Indeed I have actually been using the GX100 as a "card reader" for my Nikon's 1GB SD card since I can't get my computer to recognise the Nikon at all and I don't have a standalone card reader.)

Edit: I have just checked the camera's error history page using the technique given on one of the forum pages here but it shows no recorded errors.
 
I only experienced similar camera freeze after swapping the cards, while the camera was still ON. I knew it was a bad idea, but I did it intentionally just to see what would happen ;) But all was OK after camera OFF/ON procedure. I would try to reformat this card in PC, using FAT32?
 
Back
Top